Web/http
HTTP 웹 기본 지식 - [HTTP] #3
개발자 쿠키
2022. 8. 28. 21:58
김영한 - 모든 개발자를 위한 HTTP 웹 기본 지식을 듣고 정리한 내용입니다.
https://www.inflearn.com/course/http-%EC%9B%B9-%EB%84%A4%ED%8A%B8%EC%9B%8C%ED%81%AC/dashboard
모든 개발자를 위한 HTTP 웹 기본 지식 - 인프런 | 강의
실무에 꼭 필요한 HTTP 핵심 기능과 올바른 HTTP API 설계 방법을 학습합니다., - 강의 소개 | 인프런...
www.inflearn.com
📝목차
HTTP
- 모든 것이 HTTP
- 클라이언트 서버 구조
- Stateful, Stateless
- 비 연결성(connectionless)
- HTTP 메시지
📌모든 것이 HTTP
💡모든 것이 HTTP - HTTP 메시지에 모든 것을 전송
- HTML, TEXT
- IMAGE, 음성, 영상, 파일
- JSON, XML (API)
- 거의 모든 형태의 데이터 전송 가능
- 서버간에 데이터를 주고 받을 때도 대부분 HTTP 사용
💡HTTP 역사
- HTTP/0.9 1991년: GET 메서드만 지원, HTTP 헤더X
- HTTP/1.0 1996년: 메서드, 헤더 추가
- HTTP/1.1 1997년: 가장 많이 사용, 우레에게 가장 중요한 버전
- RFC2068 (1997) -> RFC2616 (1999) -> RFC7230~7235 (2014)
- HTTP/2 2015년: 성능 개선
- HTTP/3 진행중: TCP 대신에 UDP 사용, 성능 개선
💡기반 프로토콜
- TCP: HTTP/1.1, HTTP/2
- UDP: HTTP/3
- 현재 HTTP/1.1 주로 사용
- HTTP/2, HTTP/3도 점점 증가
💡HTTP 특징
- 클라이언트 서버 구조
- 무상태 프로토콜(stateless), 비연결성
- HTTP 메시지
- 단순함, 확장가능
📌클라이언트 서버 구조
💡클라이언트 서버 구조
- Request Response 구조
- 클라이언트는 서버에 요청을 보내고, 응답을 대기
- 서버가 요청에 대한 결과를 만들어서 응답

📌Stateful, Stateless
💡무상태 프로토콜 - 스테이트리스(Stateless)
- 서버가 클라이언트의 상태를 보존X
- 장점: 서버 확장성 높음
- 단점: 클라이언트가 추가 데이터 전송
💡Stateful, Stateless 차이
- Stateful: 상태유지
- Stateless: 무상태
- 갑자기 클라이언트 요청이 증가해도 서버를 대거 투입할 수 있다.
- 무상태는 응답 서버를 쉽게 바꿀 수 있다. -> 무한한 서버 증설 가능
💡Stateful - 상태 유지


💡Stateless - 무상태



💡Stateless - 실무 한계
- 무상태
- ex) 로그인이 필요 없는 단순한 서비스 소개 화면
- 상태 유지
- ex) 로그인
- 로그인한 사용자의 경우 로그인 했다는 상태를 서버에 유지
- 일반적으로 브라우저 쿠키와 서버 세션등을 사용해서 유지
- 상태 유지는 최소한만 사용
📌비 연결성(connectionless)
💡연결을 유지하는 모델




💡연결을 유지하지 않는 모델





💡비 연결성
- HTTP는 기본이 연결을 유지하지 않는 모델
- 초 단위 이하의 빠른 속도로 응답
- 수천명이 서비스를 이용해도, 동시에 처리하는 요청을 수십개 이하로 매우 적음
- 서버 자원을 매우 효율적으로 사용할 수 있음
💡비 연결성 - 한계와 극복
- TCP/IP 연결을 새로 맺어야 함 - 3 way handshake 시간 추가
- 웹 브라우저로 사이트를 요청하면 HTML 뿐아니라 자바 스크립트, css, 추가 이미지 등 수 많은 자원이 함께 다운로드
- HTTP 지속연결로 문제 해결
- HTTP/2, HTTP/3에서 더 많은 최적화
💡HTTP 초기 - 연결, 종료 낭비

💡HTTP 지속 연결(Persistent Connections)

📌HTTP 메시지
💡모든 것이 HTTP - HTTP 메시지에 모든 것을 전송
- HTML, TEXT
- IMAGE, 음성, 영상, 파일
- JSON, XML
- 거의 모든 형태의 데이터 전송 가능
- 서버간 데이터를 주고 받을 때 대부분 HTTP 사용



💡시작 라인 - 요청 메시지
- start-line = request-line / status-line
- request-line = method SP(공백) request-target SP HTTP-version CRLF(엔터)
- HTTP 메서드 (GET: 조회)
- 요청대상 (/search?q=hello&hl=ko)
- HTTP Version
💡시작 라인 - 요청 메시지 HTTP 메서드
- 종류: GET, POST, PUT, DELETE...
- 서버가 수행해야 할 동작 지정
- GET: 리소스 조회
- POST: 요청 내역 처리
💡시작 라인 - 요청 대상
- absolute-path[?query] (절대경로[?쿼리])
- 절대경로 = "/"로 시작하는 경로
💡시작 라인 - 응답 메시지
- start-line = request-line / status-line
- status-line = HTTP-version SP status-code SP reason-phrase CRLF
- HTTP 버전
- HTTP 상태 코드: 요청 성공, 실패를 나타냄
- 200: 성공
- 400: 클라이언트 요청 오류
- 500: 서버 내부 오류
💡HTTP 헤더
- header-field = field-name ":" OWS field-value OWS (OWS:띄어쓰기 허용)
- field-name은 대소문자 구문 없음
- HTTP 전송에 필요한 모든 부가정보
- ex) 메시지 바디의 내용, 메시지 바디의 크기, 압축, 인증, 요청 클라이언트(브라우저) 정보, 서버 애플리케이션 정보, 캐시 관리 정보...
💡HTTP 메시지 바디 - 용도
- 실제 전송할 데이터
- HTML 문서, 이미지, 영상, JSON 등 byte로 표현할 수 있는 모든 데이터 전송 가능